BluePay gateway issue
Incident Report for eCatholic
Resolved
This incident has been resolved; all systems are stable.
Posted May 19, 2022 - 12:12 CDT
Monitoring
BluePay has implemented a fix and is now monitoring, Donations and Payments forms are now available.
Posted May 19, 2022 - 08:11 CDT
Investigating
BluePay, the payment processor for eCatholic Payments, has reported an outage. Donation and Payment forms for eCatholic Payments are displaying an error as a result. We will post an update to this issue as soon as the BluePay issue is resolved, at which time the Donation and Payment forms will once again be functional. Status updates from BluePay are available here: https://status.bluepay.com/
Posted May 19, 2022 - 08:03 CDT
This incident affected: Payments (Donation Forms).