eCatholic Payments Submission Issue
Incident Report for eCatholic
Resolved
This incident has been resolved.
Posted Jan 08, 2021 - 09:35 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2021 - 09:07 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 08, 2021 - 09:04 CST
Investigating
We are currently investigating an issue where payments are not completing successfully. Our development team is actively investigating, and we will post here as updates become available.
Posted Jan 08, 2021 - 08:50 CST
This incident affected: eCatholic Payments (Donation Forms).